CameronW

Taking a look at Pop!_OS 19.04

Jun 25, 2019

Developed by System76 - a leader within OpenSource realm in regards to providing systems running Linux. In 2018 - they decided to release a Ubuntu-based OS which works out of the box with a major emphasis on end user experience.

I have a Probook 4530s; which I'm using as a Linux Laptop. It functions great - which previously had Parrot Security OS - which got shutdown and a bunch of paper and stuff ended on top it. For several months... This has been ugpraded with a 1080p display.

Requirements

Thoughts

I'm not a great big of GNOME 3 - but Pop!_OS has convinced me, that it can be cleaned up and refined enough to be a decent consideration to actually use it.

I love the clean modern icon design for every aspect of Pop!_OS. The "app store" is pulled from Elementary OS - which shares the same inspiration for a clean open, simplistic design *although Elementary appears to be heavily inspired from a MacOS point of view*... Although I did enjoy what Elementary OS did attempt to do with their distro, it failed on stability for me. Pop!_OS is a heavily curated, refined and elegant experience, while maintaining it as a professional quality desktop experience for the Novice or the experienced Linux professional.

UEFI Boot Workaround

So I attempted to install Pop!_OS 19.04 as a standard installation, allowing it to create its own partitions - unknown to me at the time that it was systemd-boot. This is a more modern bootloader to the traditional and popular grub2 bootloader that supports Legacy & UEFI systems.

I had issues after installation, every single time it displayed this error message.

Boot Device Not Found
Please install an operating system on your hard disk.

Hard Disk (3F0)

F2   System Diagnostics

Booting my live media again, GParted said that I had

/dev/sda1   ext4    /
/dev/sda2   linux-swap

So I made remade the partitions and assigned them the mount points using the installer,

PARTITION   FILESYSTEM      MOUNT       SIZE
---------------------------------------------
/dev/sda1   FAT32           /boot       512M
/dev/sda2   ext4            /           ~
/dev/sda3   linux-swap      swap        4096M

Using the installer (Manual configuration) to assign the FAT32 sda1 partition to /boot and then the sda2 ext4 partition to / (root) and then assigning the sda3 swap to swap (which you generally don't have to do, if you have like 8GB+ of system RAM)

Ran the Pop!_OS installation again, rebooted the system and presto! Pop!_OS booted no issues!